字符串搜索

按名称查找过程

选择工具 > 查找过程 (Tools > Find procedure)或按下Ctrl+T。输入完整的过程名称或其显著部分。搜索范围涵盖项目树,因此您无需知道哪个模块或类包含该过程。如果多个名称匹配,结果列表将包含所有匹配的条目;双击所需的条目以打开它。

搜索显示的文本或整个项目

选择工具 > Find string (Tools > Find string)或按下Ctrl+F以打开文本搜索对话框。选中在活动窗口 (In active window)时,搜索将应用于当前显示的代码或窗体数据。清除此复选框以在整个反编译项目中进行搜索。

文本搜索对话框,包含活动窗口和项目范围搜索模式

在字符串 (String)中输入文本并选择查找 (Find)。使用查找下一个 (Find next)继续搜索相同的文本。取消 (Cancel)关闭对话框。

搜索全部反编译文本需要完整反编译。禁用 快速反编译 (Fast decompilation)(位于高级功能),然后重新处理文件。按名称搜索过程是针对项目结构执行的另一项操作。

搜索字符串引用

如果您需要字符串字面量以及使用它们的代码,请打开字符串引用。其搜索 (Search)字段和查找下一个按钮用于搜索字符串列表。字符串引用可以通过在快速反编译模式下进行初步反汇编来收集;它们不需要搜索每个完全反编译的过程。